Blog

Sucuri WordPress vulnerability disclosure

Over 1 million sites with NextGen plugin installed vulnerable

Published on March 2, 2017 | 0 comment

Just over two weeks ago, over 2 million WordPress web pages were defaced due to vulnerability in the core software. A few days ago, another serious vulnerability was published by Sucuri that affects over 1 million WordPress websites that have the NextGen image gallery plugin installed. With Strattic, even if your site has vulnerabilities, it’s…

Read More
Let's Encrypt free SSL

Free SSL certificates for everyone: how to get one and implement it correctly

Published on September 29, 2016 | 5 comment

  The introduction of free SSL certificates to the web is a significant step forward in the security of the internet. Although SSL certificates encrypt a site’s information and therefore make it more secure, until recently most websites wouldn’t even consider implementing SSL certificates on their site. The only sites that were¬†using SSL certificates were¬†applications…

Read More